import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "decided\\s+by\\s+(?P<presiding_judge>[A-Za-z]+)\\s*,\\s+Presiding\\s+Judge;\\s+(?P<judge>[A-Za-z]+)\\s*,\\s+Judge;\\s+and\\s+(?P<extra_jusdges>[A-Za-z,\\s]+)\\s*,\\s+Judge\\.?";
final String string = "Considered and decided by Hemingway, Presiding Judge; Bell, \n"
+ "Judge; and\n\n"
+ "Dickinson, Emily, Judge\n"
+ "Considered and decided by Einstein, Presiding Judge; Abel, \n"
+ "Judge; and\n\n\n"
+ "Lagrange, Gauss, Judge\n"
+ "Considered and decided by Newton, Presiding Judge; Dirichlet, \n"
+ "Judge; and\n\n\n"
+ "Fourier, Cauchy, Judge";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}