re = /decided\s+by\s+(?P<presiding_judge>[A-Za-z]+)\s*,\s+Presiding\s+Judge;\s+(?P<judge>[A-Za-z]+)\s*,\s+Judge;\s+and\s+(?P<extra_jusdges>[A-Za-z,\s]+)\s*,\s+Judge\.?/m
str = 'Considered and decided by Hemingway, Presiding Judge; Bell,
Judge; and
Dickinson, Emily, Judge
Considered and decided by Einstein, Presiding Judge; Abel,
Judge; and
Lagrange, Gauss, Judge
Considered and decided by Newton, Presiding Judge; Dirichlet,
Judge; and
Fourier, Cauchy, Judge'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end