# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\D*//gm;t' <<< "Hand knotted in Iran (Persian)<br>Wool on wool<br>3.6m x 2.8m<br>11' 10\" x 9' 2\""