use strict;
my $str = '"author":"Lucy Bode","publisher":{"name":"Channel Void"
"author":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":"Lucy Bode","publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":"Lucy Bode","publisher":{"name":"Channel Void"
"authors":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"@type":"Person","name":"Lucy Bode"}
"image":{"@type":"ImageObject","url":"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267","width":1900,"height":1267,"author":{"@type":"Person","name":"Ed Marshall, Redonda Restoration Programme"},';
my $regex = qr/"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\[?(?:"name":)?"|")([^"\\]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}