re = /"(?:[Aa]uthor[s]?|[Jj]ournalist|[Pp]erson)":(?:{(?:[^}[]+)?"name[s]?":\[?(?:"name":)?"|")([^"\\]+)/m
str = '"author":"Lucy Bode","publisher":{"name":"Channel Void"
"author":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":"Lucy Bode","publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"journalist":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":"Lucy Bode","publisher":{"name":"Channel Void"
"authors":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"authors":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"name":"Lucy Bode"},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["name":"Lucy Bode"]},"publisher":{"name":"Channel Void"
"Person":{"names":["Lucy Bode"]},"publisher":{"name":"Channel Void"
"author":{"@type":"Person","name":"Lucy Bode"}
"image":{"@type":"ImageObject","url":"https://static.nationalgeographic.co.uk/files/styles/image_3200/public/rewilding-redonda.jpg?w=1900&h=1267","width":1900,"height":1267,"author":{"@type":"Person","name":"Ed Marshall, Redonda Restoration Programme"},'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end