# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)/Lorem $1 AAA \$1 BBB $1 Lorem/gs;t' <<< "Lorem"