#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(\w+)"
Local $sString = "Lorem"
Local $sSubst = "Lorem $1 AAA \$1 BBB $1 Lorem"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)