// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(\w+)").unwrap();
let string = "Lorem";
let substitution = "Lorem $1 AAA \\$1 BBB $1 Lorem";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}