use strict;
my $str = 'Lorem';
my $regex = qr/(\w+)/sp;
my $subst = 'Lorem $1 AAA \\$1 BBB $1 Lorem';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";