import Foundation
let pattern = #"(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"Lorem"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"Lorem $1 AAA \$1 BBB $1 Lorem"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)