# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\\/)//gm;t' <<< "1,258\xa0sq\xa0mi (3,260\xa0km2)
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
234,878
45\xa0sq\xa0mi (120\xa0km2) \xa03.6%
194/sq\xa0mi (75/km2
"