// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)").unwrap();
let string = "1,258\\xa0sq\\xa0mi (3,260\\xa0km2)
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
234,878
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
194/sq\\xa0mi (75/km2
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}