const regex = /((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\d*,*\\d*\\d)\\\\)|(\\d*,\\d*)|((\\d*)\\\/)', 'gm')
const str = `1,258\\xa0sq\\xa0mi (3,260\\xa0km2)
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
234,878
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
194/sq\\xa0mi (75/km2
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);