use strict;
my $str = '1,258\\xa0sq\\xa0mi (3,260\\xa0km2)
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
234,878
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
194/sq\\xa0mi (75/km2
';
my $regex = qr/((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";