re = /((\d*,*\d*\d)\\)|(\d*,\d*)|((\d*)\/)/m
str = '1,258\\xa0sq\\xa0mi (3,260\\xa0km2)
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
234,878
45\\xa0sq\\xa0mi (120\\xa0km2) \\xa03.6%
194/sq\\xa0mi (75/km2
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result