# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+\s?)(days|weeks|hours)(.*)/in \g<0>/gm;t' <<< "2 hours"