package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+\s?)(days|weeks|hours)(.*)`)
var str = `2 hours`
var substitution = "in \g<0>"
fmt.Println(re.ReplaceAllString(str, substitution))
}