import re
regex = re.compile(r"(\d+\s?)(days|weeks|hours)(.*)", flags=re.MULTILINE)
test_str = "2 hours"
subst = "in \\g<0>"
result = regex.sub(subst, test_str)
if result:
print(result)