$re = '/(\d+\s?)(days|weeks|hours)(.*)/m';
$str = '2 hours';
$subst = "in \g<0>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;