re = /(\d+\s?)(days|weeks|hours)(.*)/m
str = '2 hours'
subst = 'in \\g<0>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result