using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b'\b(*SKIP)(*FAIL)|'";
string substitution = @"""";
string input = @"'I don't go to work tomorrow 2'5'";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}