#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES"
Local $sString = "NOME: TESTE DE SILVA SAURO " & @CRLF & _
"CPF: 785.981.970-84 " & @CRLF & _
"IMPOSTO SOBRE A RENDA - PESSOA FÍSICA " & @CRLF & _
"DECLARAÇÃO DE AJUSTE ANUAL " & @CRLF & _
"EXERCICIO 2018 ANO-CALENDÁRIO 2017 " & @CRLF & _
"TOTAL " & @CRLF & _
">62.715,90 " & @CRLF & _
"" & @CRLF & _
"DEDUÇÕES" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")