package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES`)
var str = `NOME: TESTE DE SILVA SAURO
CPF: 785.981.970-84
IMPOSTO SOBRE A RENDA - PESSOA FÍSICA
DECLARAÇÃO DE AJUSTE ANUAL
EXERCICIO 2018 ANO-CALENDÁRIO 2017
TOTAL
>62.715,90
DEDUÇÕES
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}