// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES").unwrap();
let string = "NOME: TESTE DE SILVA SAURO
CPF: 785.981.970-84
IMPOSTO SOBRE A RENDA - PESSOA FÍSICA
DECLARAÇÃO DE AJUSTE ANUAL
EXERCICIO 2018 ANO-CALENDÁRIO 2017
TOTAL
>62.715,90
DEDUÇÕES
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}