using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES";
string input = @"NOME: TESTE DE SILVA SAURO
CPF: 785.981.970-84
IMPOSTO SOBRE A RENDA - PESSOA FÍSICA
DECLARAÇÃO DE AJUSTE ANUAL
EXERCICIO 2018 ANO-CALENDÁRIO 2017
TOTAL
>62.715,90
DEDUÇÕES
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}