use strict;
my $str = 'NOME: TESTE DE SILVA SAURO
CPF: 785.981.970-84
IMPOSTO SOBRE A RENDA - PESSOA FÍSICA
DECLARAÇÃO DE AJUSTE ANUAL
EXERCICIO 2018 ANO-CALENDÁRIO 2017
TOTAL
>62.715,90
DEDUÇÕES
';
my $regex = qr/TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}