# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"TOTAL\s+>(\d{1,3}(?:\.\d{3})*,\d{2})\s+DEDU.*?ES"
test_str = ("NOME: TESTE DE SILVA SAURO \n"
"CPF: 785.981.970-84 \n"
"IMPOSTO SOBRE A RENDA - PESSOA FÍSICA \n"
"DECLARAÇÃO DE AJUSTE ANUAL \n"
"EXERCICIO 2018 ANO-CALENDÁRIO 2017 \n"
"TOTAL \n"
">62.715,90 \n\n"
"DEDUÇÕES\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.