#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)"
Local $sString = "CASE " & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" ELSE <any_user_defined_value>" & @CRLF & _
"END," & @CRLF & _
"CASE " & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" ELSE <any_user_defined_value>" & @CRLF & _
"END," & @CRLF & _
"CASE " & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>" & @CRLF & _
" ELSE <any_user_defined_value>" & @CRLF & _
"END"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")