$re = '/(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)/i';
$str = 'CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);