using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)";
string input = @"CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}