use strict;
my $str = 'CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END';
my $regex = qr/(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}