re = /(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)/i
str = 'CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END,
CASE
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
WHEN <any_user_defined_condition> THEN <any_user_defined_value>
ELSE <any_user_defined_value>
END'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end