import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?:CASE\\s+(?:(?:WHEN\\s+.+\\s+THEN\\s+.+)(?:\\s+WHEN\\s+.+THEN\\s+.+)*)\\s+ELSE\\s+.+\\s+END)(?:,\\s*CASE\\s+(?:(?:WHEN\\s+.+THEN\\s+.+)(?:\\s+WHEN\\s+.+\\s+THEN\\s+.+)*)\\s+ELSE\\s+.+\\s+END)*)";
final String string = "CASE \n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " ELSE <any_user_defined_value>\n"
+ "END,\n"
+ "CASE \n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " ELSE <any_user_defined_value>\n"
+ "END,\n"
+ "CASE \n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
+ " ELSE <any_user_defined_value>\n"
+ "END";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}