import re
regex = re.compile(r"(?:(?:CASE\s+(?:(?:WHEN\s+.+\s+THEN\s+.+)(?:\s+WHEN\s+.+THEN\s+.+)*)\s+ELSE\s+.+\s+END)(?:,\s*CASE\s+(?:(?:WHEN\s+.+THEN\s+.+)(?:\s+WHEN\s+.+\s+THEN\s+.+)*)\s+ELSE\s+.+\s+END)*)", flags=re.IGNORECASE)
test_str = ("CASE \n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" ELSE <any_user_defined_value>\n"
"END,\n"
"CASE \n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" ELSE <any_user_defined_value>\n"
"END,\n"
"CASE \n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" WHEN <any_user_defined_condition> THEN <any_user_defined_value>\n"
" ELSE <any_user_defined_value>\n"
"END")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")