#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)"
Local $sString = " border: 1px solid" & @CRLF & _
"#cecfd5" & @CRLF & _
" border-radius: 6px7" & @CRLF & _
"" & @CRLF & _
"grid-template: " & @CRLF & _
" "a a a" 40px" & @CRLF & _
" "b c c" 40px" & @CRLF & _
" "b c c" 40px / 1fr 1fr 1fr;" & @CRLF & _
"color: green;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")