const regex = /(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\\:|(?<value>[\\S]+\\;?)', 'gm')
const str = ` border: 1px solid
#cecfd5
border-radius: 6px7
grid-template:
"a a a" 40px
"b c c" 40px
"b c c" 40px / 1fr 1fr 1fr;
color: green;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}