re = /(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)/m
str = ' border: 1px solid
#cecfd5
border-radius: 6px7
grid-template:
"a a a" 40px
"b c c" 40px
"b c c" 40px / 1fr 1fr 1fr;
color: green;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end