import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\\:|(?<value>[\\S]+\\;?)";
final String string = " border: 1px solid\n"
+ "#cecfd5\n"
+ " border-radius: 6px7\n\n"
+ "grid-template: \n"
+ " \"a a a\" 40px\n"
+ " \"b c c\" 40px\n"
+ " \"b c c\" 40px / 1fr 1fr 1fr;\n"
+ "color: green;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}