package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)`)
var str = ` border: 1px solid
#cecfd5
border-radius: 6px7
grid-template:
"a a a" 40px
"b c c" 40px
"b c c" 40px / 1fr 1fr 1fr;
color: green;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}