using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<ident>-?[a-zA-Z_][a-zA-Z0-9_-]+)\:|(?<value>[\S]+\;?)";
string input = @" border: 1px solid
#cecfd5
border-radius: 6px7
grid-template:
""a a a"" 40px
""b c c"" 40px
""b c c"" 40px / 1fr 1fr 1fr;
color: green;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}