#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\X{5}$"
Local $sString = "--- NFC (o "á" é representado como um único code point: U+00E1)" & @CRLF & _
"sabiá" & @CRLF & _
"--- NFD (o "á" é representado como dois code points: U+0061 U+0301)" & @CRLF & _
"sabiá"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")