$re = '/^\X{5}$/m';
$str = '--- NFC (o "á" é representado como um único code point: U+00E1)
sabiá
--- NFD (o "á" é representado como dois code points: U+0061 U+0301)
sabiá';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);