import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\X{5}$";
final String string = "--- NFC (o \"á\" é representado como um único code point: U+00E1)\n"
+ "sabiá\n"
+ "--- NFD (o \"á\" é representado como dois code points: U+0061 U+0301)\n"
+ "sabiá";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}