package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\X{5}$`)
var str = `--- NFC (o "á" é representado como um único code point: U+00E1)
sabiá
--- NFD (o "á" é representado como dois code points: U+0061 U+0301)
sabiá`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}