using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\X{5}$";
string input = @"--- NFC (o ""á"" é representado como um único code point: U+00E1)
sabiá
--- NFD (o ""á"" é representado como dois code points: U+0061 U+0301)
sabiá";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}