const regex = /^\X{5}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\X{5}$', 'gm')
const str = `--- NFC (o "á" é representado como um único code point: U+00E1)
sabiá
--- NFD (o "á" é representado como dois code points: U+0061 U+0301)
sabiá`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}