re = /^\X{5}$/m
str = '--- NFC (o "á" é representado como um único code point: U+00E1)
sabiá
--- NFD (o "á" é representado como dois code points: U+0061 U+0301)
sabiá'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end