#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->"
Local $sString = "<!--product_template this is some extra text -->" & @CRLF & _
"<table class='template'></table>" & @CRLF & _
"<!--end_product_template-->" & @CRLF & _
"" & @CRLF & _
"non-commented text might exist in the document" & @CRLF & _
"" & @CRLF & _
"<div>As will other tags</div>" & @CRLF & _
"" & @CRLF & _
"<!--product_template this is some different extra text--><table class='template'></table><!--end_product_template-->" & @CRLF & _
"" & @CRLF & _
"<!--product_template--><p><!--end_product_template-->" & @CRLF & _
"" & @CRLF & _
"<!--product_template--><!--end_product_template-->" & @CRLF & _
"" & @CRLF & _
"<!--product_template--><table class='template'></table><!--end_product_template-->" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")