$re = '/<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->/s';
$str = '<!--product_template this is some extra text -->
<table class=\'template\'></table>
<!--end_product_template-->
non-commented text might exist in the document
<div>As will other tags</div>
<!--product_template this is some different extra text--><table class=\'template\'></table><!--end_product_template-->
<!--product_template--><p><!--end_product_template-->
<!--product_template--><!--end_product_template-->
<!--product_template--><table class=\'template\'></table><!--end_product_template-->
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);