import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!--product_template(?:(?!<!--product_template).)*?<table.*?<!--end_product_template-->";
final String string = "<!--product_template this is some extra text -->\n"
+ "<table class='template'></table>\n"
+ "<!--end_product_template-->\n\n"
+ "non-commented text might exist in the document\n\n"
+ "<div>As will other tags</div>\n\n"
+ "<!--product_template this is some different extra text--><table class='template'></table><!--end_product_template-->\n\n"
+ "<!--product_template--><p><!--end_product_template-->\n\n"
+ "<!--product_template--><!--end_product_template-->\n\n"
+ "<!--product_template--><table class='template'></table><!--end_product_template-->\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}